Category : Technology

Linux

Pidgin: Impossibile validare certificato omega.contacts.msn.com

Da qualche giorno, chi usa Pidgin come programma di messaggistica istantanea, si sarà accorto che c’è un problema quando tenta di accedere sulla rete MSN per via del certificato ssl per l’host omega.contacts.msn.com.

Il problema è nato dal fatto che il certificato ssl è stato cambiato ma pidgin non forza l’aggiornamento.

Per risolvere il problema bisogna agire manualmente sostituendo l’attuale certificato scaricato da pidgin con quello effettivo di *.contacts.msn.com

I files da modificare con un qualsiasi editor di testo puro sono i seguenti (per windows usate notepad, per linux gedit o vim):

WINDOWS: %appdata%.purplecertificates|x509tls_peersomega.contacts.msn.com

LINUX: /home/USER/.purple/certificates/x509/tls_peers/omega.contacts.msn.com

Cancellate tutto il contenuto e mettete questo:

—–BEGIN CERTIFICATE—–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—–END CERTIFICATE—–

Riavviate pidgin e non dovreste riscontrare più problemi.

UPDATE 2010-11-23: gli sviluppatori di pidgin hanno finalmente segnalato il problema e indicato la prossima settimana per l’uscita della nuova versione del programma con i nuovi certificati.

Come workaround quanto detto sopra non basta: attualmente basta cancellare da Strumenti -> Certificati di pidgin il certificato di omega.contacts.msn.com. Chiudere pidgin e scaricare questi due certificati:

http://developer.pidgin.im/viewmtn/revision/downloadfile/cd236baf6d00f3e1561a40974ce1828b793ea187/share/ca-certs/Microsoft_Internet_Authority_2010.pem

http://developer.pidgin.im/viewmtn/revision/downloadfile/cd236baf6d00f3e1561a40974ce1828b793ea187/share/ca-certs/Microsoft_Secure_Server_Authority_2010.pem

E spostarli in:

WINDOWS: C:ProgrammiPidginca-certs

LINUX: /usr/share/purple/ca-certs

Riavviare pidgin e non avrete più problemi.

Read More
cPanel Linux

cPanel e Munin: le statistiche di mysql non vengono generate

Quando si cambia la password di root di mysql e si ha cPanel con il plugin di Munin installato, capita che il munin-node non aggiorni le statistiche di MySQL.

Per ovviare a questo problema,

Read More
Linux Plesk

Plesk Linux – Forzare aggiornamenti AWStats

Plesk su linux ha molti tool seminascosti nell’assurda (a mio dire) struttura di directory interne.

Per esempio c’è un comando molto utile per forzare l’aggiornamento delle statistiche AWStats del proprio dominio.

Di seguito il comando valido per l’ipotetico dominio miodominio.it:

/usr/local/psa/admin/sbin/statistics --calculate-one --domain-name=miodominio.it

Possiamo anche far girare lo stesso script per tutti i domini in questo modo:

/usr/local/psa/admin/sbin/statistics –calculate-all

Read More
Linux Plesk

Plesk – Centos 5.4 x86_64 – Installazione in caso di errori

Su una distribuzione pulita di CentOS 5.4 x86_64, in fase di installazione di Plesk 9.3, puo’ capitare questo errore:

Determining the packages that need to be installed.
Unhappy catched; try to resolve again.
The requested package “psa” could not be installed.
Searching problems for the “psa” package.
No suitable solutions were found for the “bind >= 9.2.1” dependency.
The “bind-30:9.3.4-10.P1.el5_3.3.x86_64” package resolves “bind >= 9.2.1”.
Could not add package bind-libs-30:9.3.6-4.P1.el5.x86_64to the list of required packages.Problem occured during searching directly resolved dependencies for ‘libbind9.so.0()(64bit)’ of package bind-30:9.3.4-10.P1.el5_3.3.x86_64 ERROR: Unable to install the “psa-9.2.3-cos5.build92091016.19.x86_64” package.
Not all packages were installed.
Please, contact product technical support.

Per risolverlo basta installare:

yum install cyrus-sasl-md5 db4-utils bind

Subito dopo puliamo la cache di yum:

yum clean all

E facciamo ripartire l’installazione 🙂

Read More
1 2 3 4 5 15